How To Configure VLANs, And Assign IP Address To The VLANs Interface.

CREATING OUR VLANs

Switch#enable
Switch#configure terminal

Switch(config)#VLAN 500
Switch(config-vlan)#NAME RED
Switch(config-vlan)#EXI
Switch(config)#
Switch(config)#VLAN 600
Switch(config-vlan)#NAME GOLD
Switch(config-vlan)#EXI
Switch(config)#
Switch(config)#VLAN 700
Switch(config-vlan)#NAME GREEN
Switch(config-vlan)#EXI
Switch(config)#

LET’S VERIFY OUR CREATED VLANS

Switch#Show vlan

VLAN            Name                  Status                          Ports
—- ——————————– ——— —————————————————–
1                    default                active                        Fa0/1, Fa0/2, Fa0/3, Fa0/4
                                                                                      Fa0/5, Fa0/6, Fa0/7, Fa0/8
                                                                                      Fa0/9, Fa0/10, Fa0/11, Fa0/12
                                                                                      Fa0/13, Fa0/14, Fa0/15, Fa0/16
                                                                                      Fa0/17, Fa0/18, Fa0/19, Fa0/20
                                                                                      Fa0/21, Fa0/22, Fa0/23, Fa0/24
500              RED                        active
600              GOLD                     active
700              GREEN                   active
1002         fddi-default             act/unsup
1003     token-ring-default     act/unsup
1004       fddinet-default         act/unsup
1005       trnet-default             act/unsup

ASSIGN INTERFACES TO THE VLANS

Switch(config)#int range fa0/1 – fa0/2
Switch(config-if-range)#switchport mode access
Switch(config-if-range)#switchport access vlan 500
Switch(config-if-range)#exit
Switch(config)#
Switch(config)#int range fa0/3 – fa0/4
Switch(config-if-range)#switchport mode access
Switch(config-if-range)#switchport access vlan 600
Switch(config-if-range)#exit
Switch(config-if-range)#
Switch(config)#interface range fa0/5 – fa0/6
Switch(config-if-range)#switchport mode access
Switch(config-if-range)#switchport access vlan 700
Switch(config-if-range)#exit
Switch(config)#exit

LET’S VERIFY OUR INTERFACE RANGE ASSIGNED TO EACH CREATED VLAN

Switch# show vlan

VLAN         Name                  Status                      Ports
—- ——————————– ——— ———————————————————–
1                default                   active                    Fa0/7, Fa0/8, Fa0/9, Fa0/10
                                                                                 Fa0/11, Fa0/12, Fa0/13, Fa0/14
                                                                                 Fa0/15, Fa0/16, Fa0/17, Fa0/18
                                                                                 Fa0/19, Fa0/20, Fa0/21, Fa0/22
                                                                                 Fa0/23, Fa0/24
500            RED                        active                    Fa0/1, Fa0/2
600            GOLD                     active                    Fa0/3, Fa0/4
700            GREEN                   active                    Fa0/5, Fa0/6
1002      fddi-default              active
1003    token-ring-default    active
1004    fddinet-default          active
1005      trnet-default            active
Switch(config)#

ASSIGN IP ADDRESS TO VLAN INTERFACE

Switch(config)#interface VLAN 500
Switch(config-if)#IP address 192.168.1.1 255.255.255.192
Switch(config-if)#exit
Switch(config)#
Switch(config)#interface VLAN 600
Switch(config-if)#IP address 192.168.1.65 255.255.255.192
Switch(config-if)#exit
Switch(config-if)#
Switch(config)#interface vlan 700
Switch(config-if)#ip address 192.168.1.129 255.255.255.192
Switch(config-if)#exit
Switch(config-if)#

Read More